Skewed Encoder Waveform

I received this e-mail from a potential customer who is trying to determine why his Encoder waveform doesn’t look right.  His name has been changed to protect his identity.

Hi Jim

I have just come across your Web page on RPM calculation using an optical encoder and oscilloscope. I was keen to test out this method of RPM calculation so rigged up my little encoder and oscilloscope without hesitation. I don’t seem to be getting a nice wave wave form across my display, its rather skewed. Could you just point out where I’m going wrong?

Really enjoyed reading your articles. Look forward to hearing back from you soon.

Eddie

Eddie’s photos are below:

Hi Eddie,

I would love to say the problem is that you aren’t using a Quantum Encoder….

But instead it looks like you are just missing a ground reference for the scope.   There is usually a little black alligator clip hanging off the side of the scope probe. That clip needs to be attached to the signal common on the encoder (black or negative on the power supply)

The red arrow below indicates where the ground clip should connect to the scope probe.

The reason your waveform looks  skewed is because the absence of a ground reference causes the scope to pick up ambient 60 Hz noise (it is everywhere, outlets, lights etc.) and couple it with your encoder signal.

Connecting the scope ground to the incremental encoder signal common will clear that right up.

Below is a picture of a scope probe with the ground clip.

Take care,

Jim

Jim Miller is a Design/Application engineer working for Quantum Devices Inc.

He can be reached at (608) 924-3000, or via e-mail at jmiller@quantumdev.com.

Advertisements